Windows Server 2016 で Let's Encrypt の実行について

ここでは Windows Server 2016 にて Let's Encrypt(wacs.exe)の実行時に発生した問題点の回避方法について記載しています

wacs.exe が起動出来ない

https://github.com/PKISharp/win-acme/releases からダウンロードした
V2.0.6.277を使用して wacs.exeを実行しましたが
.NET Framework,Version=v4.7.2が無いとしてエラーになり
Framework.4.7.2のインストールに進みましたが、インストールがエラーになりました。

そこで、 手動で、Framework 4.7.2を
https://support.microsoft.com/ja-jp/help/4054530/microsoft-net-framework-4-7-2-offline-installer-for-windows
からダウンロードしてインストールをしましたが、同様にエラーとなりました

その後、Microsoft Updateカタログ
http://www.catalog.update.microsoft.com/Home.aspx
から KB4054590を検索して、

Windows Server 2016用のプログラム
(Windows 10 LTSB,Windows Server 2016)

をダウンロードして、インストールしたところ、
正常にインストールが出来ましたので
wacs.exeは、正常に起動出来ました。
(注意点 インストール後に再起動が必要です)

〒160-0004 東京都新宿区四谷2-8 クローバビル 804 ピイジェイ
Mail: freeinfo@pjc.co.jp